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What’s New 

If you’re new to myhomefiling, then the chapter on Getting Started is the best place for you to 

start learning about the software, its features and how to make it work for you.  If on the other 

hand, you’ve already used or are using the software at present, then you can find a summary of 

the program changes below, with quick links to the relevant sections in this guide. 

 

Change Log 

  Version   New    Changed  Removed 

  4.1.7    Minor fixes     

  4.1.6    Full screen document view 
  Open in default viewer 

  Advanced Search    

  4.1.4    Add Cabinets & Folders 
  Export to iCalendar 
 

  Reminders 
 

   

  3.0 r1    Bulk Scanning 
  InTray 
  Watch Folder 
  Trash 

  PDF File Support 
  Search 
  myhomefiling Monitor 
  Status Bar 
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Getting Started 

Before using myhomefiling, please take the time to read through this guide and familiarise 

yourself with the controls and features available to you.  The guide itself is structured so that it 

can be read from beginning to end or as a quick reference for specific actions/features.   

 

If you haven’t already installed myhomefiling, or you are having difficulties installing 
myhomefiling, please refer to the ‘myhomefiling Installation Guide’ for details on how to 
install the software.  If you are still having trouble installing the software, please refer to 
the Notices chapter on ways to contact Xpress Document Solutions Limited for further 
assistance. 

 

No specialist knowledge is required to use myhomefiling as all of the programs features and 

functions are covered in detail from here on in; you will need at least a basic understanding of the 

Microsoft Windows desktop operating system to be able to use the software to its fullest. 

About myhomefiling 

The myhomefiling software is a document filing program, designed and developed by Xpress 

Document Solutions Limited.  The purpose of the software is to provide a low cost, feature rich 

solution to the problems associated with filing documents in the home. 

 

This effective tool can be used to help reduce the unnecessary clutter caused by storing historical 

paper records.  Where documents have to be retained (legal, financial etc) it can be used to 

create “local” electronic copies of those documents, while the original documents can be put out 

of the way (such as a loft) – freeing up space and ensuring easier, faster access to the records 

when you need them. 

 

myhomefiling isn’t just for filing paper documents; you can also use it to file your paperless 
billing statements from utility providers and banks.  Just thought we’d drop that in there, 
just in case you didn’t know. 

 

Software Licensing 

myhomefiling is installed with a 45 day evaluation license.  During this time, you may use the 

program as much as you wish, without any restrictions.  After this time, you’ll be unable to add 

new documents to the Vault, but you will still be able to access all of the documents you have 

already added.  To continue using the software without restriction you will need to purchase a 

licence from our web site.   

 

Software licensing within myhomefiling is as straight forward as the program itself, you purchase 

a license for each computer that you wish to install the software on and that’s it.   
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Starting myhomefiling 

If you have installed myhomefiling to its default location, you can start the program by following 

these instructions: 

 

1. Click Start 

2. Select the All Programs menu item from the Windows Start Menu 

3. Select the myhomefiling start menu folder 

4. Click myhomefiling 

 

 If you selected a different start menu folder when myhomefiling was installed, select that folder 

in step three above instead. 

 

Previous Versions of myhomefiling 

If you installed myhomefiling v3 (or higher) onto a computer where you originally had 

myhomefiling v1, you will need to run the upgrade wizard in order for you to see your existing 

documents from within the new program.  This isn’t a complicated process, because the program 

will do everything for you when you first start it – all you’ll need to do is click OK on the upgrade 

wizard screen. 

 

The upgrade wizard goes a little something like this: 

 

1. Start myhomefiling 

2. When you see the wizard screen, click OK to begin the upgrade 

 

 
 

You may have noticed that the message box says myhomefiling v2 not v3; it’s there 
because the database upgrades from v1 to v3 are incremental, which means that it 
needs to be upgraded to v2 first. Also, if there’s a problem, it helps with support 
queries as it’s easy to spot which upgrade was taking place without the need for us 
to ask you to dig through the log files 



 

 

8 myhomefiling 

User Guide - Page 8 of 74 

 

 

 

 

3. The upgrade will process the existing document you have in your v1 Vault. A screen will 

appear showing the progress of the upgrade. 

 

 
 

If you accidentally click Cancel, never fear, you can try again by both closing and re-
opening the program or by clicking the Run Upgrade Wizard entry in the Tools 
menu.  The latter menu entry only appears when you cancel an upgrade. 
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Exploring the Program 

myhomefiling has been designed from the ground up with ease of use as the top priority, why? 

Because what is the point of having a program that you can’t use?  We’ve done this with 

myhomefiling by clearly grouping the programs around six key areas; the main menu, the toolbar, 

the Vault, Reminders, the Viewer and the Status Bar. 

 

 
 

The Main Menu 

File Menu 

The File menu consists of three items; the first of these (Add a Document) is used to start the 

step by step wizard that will guide you through adding your documents to the myhomefiling Vault 

(we go through this together later, so don’t worry that we’re skipping through quickly).  The 

second thing you’ll see is the Add Documents in Bulk option, which can be used in a scan now, 

file later sort of way (again, this is covered later on, so you only need to remember where it is for 

now).  Finally what you’ll see in this menu is Exit and if you’ve used windows programs before, 

then this will come as no surprise; clicking Exit will close myhomefiling quick as a flash! 
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View Menu 

Two features introduced with myhomefiling v3 are the InTray and Trash.  On the View menu, 

you’ll find shortcuts to access both of these areas of the program. 

 

The View menu is just one of the ways that the InTray and Trash can be accessed, the other 
ways to get to the same function include the Status Bar and the myhomefiling Monitor 

 

Also on the View menu you will find shortcuts that you can use to switch between the Vault and 

Reminders.  

Tools Menu 

All of the myhomefiling Options are tucked neatly away in the Tools menu.  Here you’ll find the 

tools you need to do all the not so interesting (but necessary) jobs like making backups and 

restoring your Vault.  

Help Menu 

Last but not least in our main menu list is the Help menu.  This helpful fellow is home to nine 

(that’s right nine!) shortcuts and links that are all designed to put myhomefiling support, news, 

updates etc right at your fingertips; no more hunting through printed manuals, or googling for 

forums – it’s a veritable cornucopia of usefulness. 

 

Our first shortcut is to the very document you’re currently reading!  Open Help File will attempt 

to open this document on your computer (this does require a PDF reader – and we recommend 

Foxit Reader if you haven’t already got one).  If you’re going to be using the Bulk Scanning 

function of the program, then you’ll most definitely need to know about the next shortcut and 

that’s Open Barcode Separator Page.  Clicking this shortcut will attempt to open the single 

barcode separator page on your computer (installing that PDF reader was probably as wise 

choice, as it will be needed here too). 

 

Next up we have three highly useful shortcuts to all of the myHomeFiling.com related web pages.  

Obviously myHomeFiling Web Site will open up an internet browser and immediately direct it to 

yellow pages..!! erm, no, sorry, http://www.myhomefiling.com  

 

Sometimes, it’s just easier to ask someone how you do something or how to overcome a 

problem, and although we try and keep our documentation and FAQ up to date, sometimes the 

answers to some problems won’t always be there (just yet).  Never fear, our support guys are 

here and by clicking the Contact Support link, you’ll see a new email with the address details 

already pre-populated.  Type your query or question, hit send and we’ll get back to you ASAP. 

 

http://www.foxitsoftware.com/pdf/reader/down_reader.htm
http://www.myhomefiling.com/
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Our target response to emails is next business day; we do aim for a same day initial 
response but at busy periods this is not always possible. 

 

Our developers are hard at work making sure myhomefiling is bug free and easy to use, but that’s 

no good if you have to keep visiting our web site to see if there are any new versions of the 

program to download.  This is where Check for Updates comes in.  If you have an internet 

connection, clicking this link will start the Checking for Updates process. 

 

The penultimate item in the Help menu is License Information.  By selecting this item from the 

Help menu, you can see how the program thinks it is licensed.  When myhomefiling is running 

with an evaluation license, the license screen will display “Evaluation”, when the program has 

been registered, you will see a screen similar to the one shown below.  When you purchase a 

license for myhomefiling, you’ll need to update your license information to remove the evaluation 

restriction. 

 

And finally from the Help menu; the obligatory About item.  Clicking this item displays the About 

screen which is where you’ll find the program version number (if our happy support chappy’s 

request it from you). 

 

The Toolbar 

 

 
 

The myhomefiling toolbar serves two purposes; firstly it’s home to the large shortcut button Add 

a Document, which does the same job as if you were to click the item in the File menu which 

shares the same name – the reason it’s here to is that it’s quicker for you – plain and simple. 

 

The second purpose however, is not a duplication of any other feature, because the toolbar is 

how you locate your documents within the Vault.  We cover all of this in great detail in the 

chapter Locating Your Documents – so if you’re having trouble locating your document, jump to 

that chapter now.  
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The Vault 

The vault is the part of the program that stores your documents.   

 

 
 

The vault lives at the heart of the myhomefiling document filing concept – which is an electronic 

version of a traditional filing system of cabinets and folders.  Within the vault, you will find the list 

of cabinets and within each cabinet you’ll find the list of folders.   

 

Out of the box there is a list of pre-defined cabinets and folders, which means myhomefiling is 

extremely easy to use.  You make the choice of where something should be filed, and that’s it.  

Once we get to the chapter on Filing Your Documents, you’ll see what we mean by ease of use! 

 

When a document is filed, the corresponding cabinet and folder will be highlighted and a number 

will be shown in brackets indicating how many documents are located in the cabinet/folder.   

 

The Vault hides a lot of powerful features that you won’t be able to use until you’ve filed 
some of your documents.  You can find out about these features by reading through the 
Hints and Tips chapter though. 
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Reminders 

Reminders have existed within myhomefiling for several releases, but mainly they were accessed 

via the myhomefiling monitor (the keen observers among you will also remember that you could 

edit the reminders via the Options screen too!!).  But now the reminders have been promoted 

within the main program so that you can use and interact with them more easily.  If you click Your 

Reminders (the keyboard shortcut Ctrl + Shift + R is much quicker by the way ) from the View 

menu, you’ll see that the Vault makes way for the Reminders, like so: 

 

 
 

There’s something quite exciting about features getting a bit of a makeover, we’re sure 
you’ll agree.  But that excitement won’t really last if the features aren’t explained, so head 
on over to Reminders Revisited to see get the low down. 

 

The Viewer 

The (document) viewer is used to display your documents back to you when you click on a 

document within the vault.  Although there is only a single viewer, what you see on the screen 

will depend on the type of document you click on in the vault.  There are four main types of 

document view which are; Image i.e. PDF, TIF, JPG, GIF etc; Office i.e. Word, Excel, PowerPoint; 

Web i.e. Web Pages and finally Text. 
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Image View 

Image view is a powerful image viewer supporting over 25 different image formats including PDF, 

GIF, JPG and TIF.  When you select an image type document in the vault, you will have access to 

page navigation and image manipulation features that will allow you zoom, rotate and magnify 

what you see on the screen.   

Page Navigation 

From the document viewer toolbar, you are able to move through multi-page documents a page 

at a time, view the page count for the document and the current page being viewed.   

 

 
 

Page and Document Rotation 

You can also perform clockwise and counter-clockwise rotation of the current document on a 

page by page or whole document basis. 

 

 

 

Display Size 

It is possible to alter how the page you are viewing is displayed on the screen by utilising the 

Zoom Presets.  By selecting the different items from this list, the displayed image will either grow 

or shrink.   

 

 
 

The three buttons which immediately follow the Zoom Presets are Zoom, Pan and Selection 

respectively and they are also used to alter how the document is displayed.  Zoom makes it 

possible to zoom into and out of a document using the left and right mouse buttons.  When 

selected, Pan allows documents to be dragged around so that portions of the document not being 

displayed can be visible.  Finally Selection allows the placement of a rectangular marker on the 

screen.  On releasing the mouse button, the preview window will zoom into the screen where the 

marker was drawn. 

 

Zoom, Pan and Selection are selectable and must be turned on and off.  Turning on one of 
the features automatically turns off a feature that was selected previous.  To return a 
document preview to its original size, select Fit to Width from the Zoom Presets. 
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Office View 

Office view allows myhomefiling to display your Microsoft Word, Excel and PowerPoint 

documents without having to open up the programs directly.  When you view one of these types 

of document you will see a “mini” version of the Microsoft program actually within myhomefiling.   

 

 
 

You can make changes to these documents as though you were editing them directly within the 

program that created them. 

 

 

 

 

The Status Bar 

myhomefiling has always had a status bar, but until version 3, this didn’t actually serve a purpose 

(one of those “but programs always have a status bar” moments).  What you’ll see now are two 

icons (with labels) in the lower right corner of the status bar. 
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These icons represent the InTray and the Trash respectively.  The number beside each icon shows 

how many documents are currently in each location.  You can click either of the icons and you’ll 

be taken to the appropriate screen (in the same way as selecting the InTray or Trash option from 

the View menu will). 
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Filing Your Documents 

It’s all well and good describing the features of the program in great detail, but we all know 

what’s really needed is step by step instructions on how to use all this nice technology to make 

filing your documents in the home a breeze. 

 

If you’ve been reading from the start (or if you haven’t but you’ve had a look around the program 

already) you’ll know about Add a Document – the button on the Toolbar or the link which resides 

in the File menu. 

 

Regardless of what you want to file, the process to file a new document with myhomefiling is the 

same (this is actually a little white lie – because you can actually file another way – but to 

understand that you’ll need to read here first, clear? Crystal? Great... read on!) 

 

Cabinets, Folders and Filing 

Before you read on, make sure you’ve got myhomefiling started.  It is?  Brilliant.  Click on the little 

‘+’ signs in vault, next to this  icon (these are cabinets if you don’t already know).  As you’ll 

see, each cabinet expands to show a list of folders (  ) and when you start to file your 

documents, you’ll be able to click the little ‘+’ signs that will appear next to the folders and you’ll 

be able to see the list of documents within each folder. 

 

Now you’re probably wondering why we’ve built myhomefiling this way?  Why is it all pre-

defined?  Well, we’ve drawn on our years of experience working with businesses and the biggest 

problem they’ve all faced is getting started – once they’re up and running, there are no real 

problems but deciding on what a document should be filed as cause’s untold hassle.  So it’s purely 

an ease of use factor – it helps you get the most from the software with the least amount of 

effort making the chore of filing more of a pleasure than it normally is. 

 

Although the Vault contains a list of predefined Cabinet and Folder names, since version 
2.1 of myhomefiling it has been possible to change these names giving you the choice to 
customize myhomefiling further.  You can find out more in the Hints and Tips chapter. 

 

Hold the Phone; You Can Now Add Your Own Cabinets & Folders! 

As you’ll have seen, we ship myhomefiling with a pre-defined list of cabinets and folders, but our 

most requested feature upgrade has been for the ability to add completely new Cabinets and 

Folders.  So, we’ve listened to our customers and from version 4.1 it’s now possible to add up to 

150 new locations where you can file your documents! 

 

Now this is a pretty big deal; so much so, that we’ve given this topic a whole chapter all to itself, 

so head over to Your Custom Cabinets and Folders to find out all the juicy information.  
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Easy as 1, 2, 3, 4 (and a little bit) 

You can file existing (electronic) documents or you can use your scanner to convert your paper 

documents into electronic files.  Whichever option you decide upon, there’s a friendly wizard to 

guide you through, so without further ado – lets file: 

 

1. From the Toolbar, click Add a Document (or you could select Add a Document from the 

File menu) 

 

  
 

2. You will now see the Add Document Wizard at step 1, which is where you tell the wizard 

where your document is.  If you will be using your document scanner i.e. capturing real 

paper documents, you need to select the first option and then specify which scanner 

you will be using.  If you’ll be filing existing, electronic documents, select the second 

option.  Once you’re done, click Next 
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If you don’t have a document scanner attached to your computer, you will not be 
able to select the first option as it will be disabled. 

 

3. Now you’ll be at the second step of the wizard.  It’s here you get to decide which 

cabinet and folder the document belongs in.  Select your cabinet (left column) and 

folder (right column) and click Next to continue 
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4. As you reach the third step of the wizard you will find that you can enter a description 

for your document and if you wish you can set a reminder for the document you’re 

filing.  When you’re set, click Next to continue 

 

 
 

5. What happens next depends on the option you selected in the first step of the wizard 

 

 If you selected 

 

a. The document I am going to add to the vault is a paper copy and I will need to 

use my scanner to create an electronic copy  

 

You will now see the document scanner control screen.  This will vary 

depending on the document scanner you have and you will need to consult with 

your document scanner documentation if you are unfamiliar with what you see 

on the screen.  Use the document scanner control screen to capture your paper 

documents.   

 

When the scanner has copied all of the pages available, you will be asked if you 

need to scan any more pages to complete the document.  If you click Yes then 

you’ll be able to add more pages to your scanner until the document is 

complete.  If you click No, you will move onto the next stage of the wizard. 
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This process of looping around to ‘append’ pages arises when you only 
have a single page (flat bed) scanner to work with and you have a multi-
page document that you need to scan. 

 

 

If you selected  

 

b. I will need to browse ‘My Documents’ to find the document I wish to add to 

the vault as it is already an electronic copy 

You’ll see a screen where you can browse your computer, and select the 

document that you wish to add to your vault. 

 

The types of electronic files that can be added to the myhomefiling vault 
depend on the programs you already have installed on your computer.  As 
standard you will be able to add image (PDF, JPG, GIF, TIF etc), text (TXT, 
LOG etc) and web (HTML, XML etc).  If you have Microsoft Office installed, 
you will also be able to add Word, Excel and PowerPoint documents to. 
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When you have selected your document, click Open to move to the final stage 

of the wizard 

 

6. The final stage of the wizard is fully automated.  Once you’ve told the program what 

options you want and where your document is, you can sit back and watch the magic 

(actually, you can sit back and watch the scrolling green bar - but you get the picture).  

When the final step is complete, the wizard will close and the vault will reload all of the 

documents.   
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Creating the searchable text information is how myhomefiling can find your 
documents when you attempt to locate them.  How fast this completes depends 
on a number of influences, including the speed of your computer processor, the 
available random access memory (RAM), the number of pages and the page 
density i.e. how many words on a page.   

 

Filing Again (But This Time with Gusto) 

Filing a document at a time is all well and good for the steady trickle of documents that arrives in 

the home (the daily post, letters from school, recipes from the internet etc) but what about the 

documents that have accumulated over time?  Can you really face scanning a decade’s worth of 

bank statements, one page at a time, and one document at a time?  No?  We didn’t think so. 

 

So, not ones to sit around and leave a problem unsolved, we’ve created two new features in 

myhomefiling; Bulk Scanning and InTray.  When used together, they’ll make the process of filing a 

large number of documents a million times better (no question about it). 

 

Bulk Scanning 

First up we have Bulk Scanning.  This beauty of a feature will do the hard part of this two stage 

process, the scanning en masse.  
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We mentioned a new option on the Help menu earlier (Open Barcode Separator Page) that 
is pretty vital for bulk scanning.  Basically, the program needs to know where one 
document ends and another starts.  That’s what this special page is designed for.  You’ll 
need to print a few copies off and put them before the first page of every document.  
Unless you have a really expensive scanner with an automatic document feeder that can 
hold 100’s of pages, you’ll only need to print a few of these pages off – they can then be 
reused once they’ve been through the scanner.  Hope that all made sense? Yes, Crystal 
clear, brilliant.  Off we go then. 

 

1. From the File menu, click Add Documents in Bulk 

 

   
 

2. You’ll now see the Bulk Scanning window.  At the top of the screen is a toolbar on 

which you’ll see a drop down list which contains the name of the scanners the program 

has detected.  Next to that is the Scan button, followed by the Cancel button concluding 

with the Save button.  The main part of the window will display your pages as 

thumbnails when they have been scanned 
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3. Select your scanner from the drop down list 

 

 
 

4. Load your prepared documents (don’t forget the Barcode Separator) into your scanner 

and click the Scan button (the green arrow) to begin scanning.  The pages of your 

documents will appear in the lower part of the screen.  Repeat this as many times as 

you need to scan your documents 

 

 
 

5. If you want to start over, there’s a button for that.  Just click the Cancel button (the red 

cross). You’ll be asked to confirm your choice, click Yes and all will be gone 
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6. When you’ve finished scanning and you’re ready to save the documents into 

myhomefiling, click the Save button (that’ll be the green circle with the tick).  A progress 

bar will displayed on the screen to indicate how much of the work is being done 

 

7. You’ll see a message box at the end saying that the documents were saved correctly 

and the Bulk Scanning window will be returned to it’s normal state.  You could scan 

more documents if you wish, or you could close the screen down.  The choice as they 

say is yours 

 

InTray 

If you think back to how single documents are filed, you’ll remember that all of the available 

choices are set before the scanning or importing takes place (where to file the document, 

whether to set a reminder etc).  When we use the Bulk Scanning feature, these choices aren’t set.  

The documents are ready, but they don’t know which part of the Vault they should go to. 

 

To cope with this indeterminate (oooh, check us with the big words) status, we created InTray.  

This is basically someplace that these documents can go, until you decide to file them away to 

their proper homes in the Vault.  But enough talk, lets show you how to open InTray and file a 

document or two. 

 

1. To open the InTray screen, from the View menu, click InTray (or you could click the 

InTray icon on the Status Bar) 
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This screen is split into three areas (columns) on the far left we have the list of 

documents that need to be filed, in the centre is the Viewer and on the far right we 

have the options. 

 

2. Select a document to be filed from the list in the far left column, this will load the 

document into the Viewer and it will populate the Description field in the far right 

column 

 

3. You may either leave the Description as it is or you can change it to something more 

relevant (such as Water Bill July 2011 for instance) 

 

4. If you need to be reminded that the document needs to be actioned at some point in 

the future, click Add a document reminder, set the date the reminder is due and pick 

what you need to be reminded about 

 

 
5. Almost done, but first you’ll need to pick the Cabinet and Folder that the document 

should be filed under 
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6. And finally, click the big old button File and hey presto, your document is now in the 

Vault 

 

So there we have it, filing using InTray in just six short steps.  Just repeat the steps 2 through 5 

until all of yur documents have been filed.  If you’ve been paying attention (and if not, why 

not…?) you’ll see that the choices available are the same as those in the Add Document wizard, 

but instead of being on separate screens, it’s all conveniently layed out on the one screen so that 

the documents can be filed quickly. 

 

Our code monkeys have tried really hard to make this new screen easy, yet quick, to use.  A 
handy tip is that you can use the Tab key to navigate the various areas of the screen, so 
you can keep your hands on the keyboard – try it and you’ll be a power user in no time! 
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Locating Your Documents 

You’ll be glad to know that locating your documents in the myhomefiling vault is even easier than 

actually adding them!  You can do things the old fashioned way and flick through every document 

in every cabinet but a) we wouldn’t be that mean and b) it doesn’t really make the product very 

useful.   

 

So what have we done?  Well, we’ve equipped the program with a powerful search engine, that’s 

all wrapped up in a nice, easy to use toolbar (aren’t we the nice ones?!) and for those of you who 

require a little more control, we have a more advanced search option just a few clicks away. 

 

Regardless of which type of search you use/prefer, if you need to start over and set the 

vault back to its initial state, you click the  button which is located to the right of 
the Search button. 

 

Obviously, if you haven’t added any documents to the vault, then no amount of technology will 

find anything.  So if you find yourself in this section, and you haven’t added any documents to 

your vault, then jump back to the chapter on Filing Your Documents before coming back here. 

Quick Search 

The quick search is accessed through the toolbar of myhomefiling and without changing anything 

it works in a similar manner to an internet search engine; you enter a word or phrase, hit enter 

and the program returns the corresponding documents.  Sounds easy?  Well it is, but just to make 

doubly sure, we’ll go through it step by step: 

 

1. Start myhomefiling (if it’s not already running) and enter a search word or phrase into 

the Search For text field and press the Enter key 

 

 
 

And there we have it!  You’ve just searched your myhomefiling vault.  Ok, we could have 

stretched that out to another step my saying click the Search button – but there really is no need. 

 

Refining (Only Slightly) 

Although the quick search is fast, at times it will locate so much information for you, that you may 

feel a little overwhelmed.  To minimise the information overload (and preserve your sanity), you 
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can restrict your results to a specific cabinet.  This adds just a single step to the previous example, 

so if you’re sitting tight and raring to go, we’ll go through it now together: 

 

1. Start myhomefiling (if it’s not already running) and enter a search word or phrase into 

the Search For text field  

 

 
 

2. Use the Search In drop down list box to select a specific cabinet to search in 

 

 
 

3. Click the Search button to get myhomefiling to search your documents 

 

And there we have it, lightening fast search, with a touch of finesse to help you get the 

information you need easily.  Now if you want total control over your searching, well, that’s a 

different story, so you’ll need the advanced search which is covered in detail next. 

 

Advanced Search 

Advanced search should really be considered as granular search (but seeing as this doesn’t sound 

so cool, we’re running with the “advanced” theme).  Why?  Because advanced search allows you 

to apply more control to the program and restrict what it can search on.  For example, when 

you’ve been using myhomefiling for a number of months you can tell the program that only 

documents which were scanned after a certain date appear in the results. 
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So how do you get to use all this granular advanced goodness then?  Well, it’s like so: 

 

1. Start myhomefiling (if it’s not already running) and press and hold the Search button to 

make the drop down menu appear 

 

 
 

2. From the drop down menu select Advanced Search and release the mouse.  This will 

bring up the Advanced Search screen 

 

 
 

3. Enter a search word or phrase into the Search For text field 

 

 
 

4. From the In Cabinet drop down list, specify the cabinet you wish to search in 

 

 
 

If you choose not to specify an individual cabinet, you will be unable to select an 
individual folder as shown in step 5.  This is entirely up to you of course; there is 
no need to specify either of these options, they’re purely there to help when 
you’re in information overload. 
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5. From the In Folder drop down list, specify the folder you wish to search in 

 

 
 

6. Finally on the advanced search screen we have the option to enable a date search.  This 

refers to either the date a document was added to the myhomefiling vault or the 

document date specified during filing.  If you tick the Enable Date Search check box, you 

will see that the radio buttons, drop down lists and the date selectors become active.  

Once you have selected which date you wish to search, from the corresponding date 

drop down list, if you select 

 

i. After 

You will be searching your vault for documents that have a corresponding date 

after the date you select in the date selector 

 

ii. Before 

You will be searching your vault for documents that have a corresponding date 

before the date you select in the date selector 

 

iii. Equal To 

You will be searching your vault for documents that have a corresponding date 

which is exactly the date you select in the date selector 

 

iv. Between 

When you select between, another date selector appears and becomes active.  

You will be searching your vault for documents that have a corresponding date 

after the date you select in the first date selector and before the date you 

specify in the second date selector 

 

7. When you’re done, click OK and your vault will be searched.  Easy peasy! 
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Your Custom Cabinets and Folders 

As we alluded to earlier in the guide, our most requested feature has gone from scribbles on 

paper to a full blown feature in the program (yes, we are chuffed, yes, there was plenty of back 

patting – what can we say, it wasn’t easy, but we got there).  So in this chapter we’ll guide you 

around the process so you can create your custom Cabinets and Folders until the cows come 

home – well, strictly speaking, not until the cows come home, there is limit to how much you can 

create – this is up to 10 Cabinets, and 15 Folders in each new Cabinet, but it’s still a lot. 

 

So, how do you create Cabinets and Folders I hear you ask?  Well, without further ado, lets’ get 

stuck right in.  If you haven’t got myhomefiling running, then now would be a good time to start 

it. 

 

Adding a Custom Cabinet to the Vault 

 

1. First up, make sure you’re looking at the Vault, so that you can see this icon (to make 

certain, click Your Vault from the View menu 

 

 
 

2. Click the small [+] icon, next to the Vault icon to change to the Vault editor; you’ll see 

the text change, and the [+] icon changes to [-] like so. 

 

 
 

3. To add a custom Cabinet to the Vault, click the Add Cabinet button at the bottom of the 

Vault editor 

 

 
 

You could also right click on the ‘white space’ inside the Vault editor, and you’ll 
see an option appear called Add Cabinet, which you can use instead of the button 
at the bottom of the Vault editor. Just another time saving feature for you.  
Aren’t we nice?   
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4.  Once you’ve clicked the button (or the menu option) you’ll see a new Cabinet icon 

appear in the list like so.  The new Cabinet will have its description highlighted ready for 

you to type in to 

 

 
5. Type the name you’d like, and press enter to set it; now that’s your first custom Cabinet 

created using the Vault editor! 

 

 
 

Cabinets themselves aren’t really that useful, what you need to add to them are Folders.  If 
you leave the Vault editor and a Cabinet doesn’t have any folders associated with it, you’ll 
see a message pop up on screen telling you that they will be hidden in the Vault until you 
add Folders to them 

 

Adding a Custom Folder to the Vault 

The steps involved in adding a custom Folder to the Vault are much the same as those of adding a 

custom Cabinet.  There is one prerequisite though, you have to have at least one custom Cabinet 

created to add your custom Folder to, otherwise it just won’t happen.  Now I know you’re excited 

to see how you do this, so let’s save on the words and get down to business. 

 

1. First up, make sure you’re looking at the Vault, so that you can see this icon (to make 

certain, click Your Vault from the View menu) 

 

 
 

 

 

 

 



 

 

35 myhomefiling 

User Guide - Page 35 of 74 

 

2. Click the small [+] icon, next to the Vault icon to change to the Vault editor; you’ll see 

the text change, and the [+] icon changes to [-] like so. 

 

 
 

3. Now highlight the custom Cabinet that you’d like to add your custom Folder to 

 

 
 

4. Click the Add Folder button at the bottom of the Vault editor 

 

 
 

You could also right click on the custom Cabinet inside the Vault editor, and you’ll 
see a menu appear. The first item on the menu is Add Folder and you’ve guessed 
it, it does the same job as the button at the foot of the Vault editor. If nothing 
else, we’re consistent. Now, what are you still doing reading this, you’ve got a 
few more steps to go. 

 

5. After you’ve clicked the button, or you’ve selected the item from the menu.  Your new 

custom Folder will appear, waiting, no begging you (ok, we may have made that bit up), 

to enter a meaningful name 

 
 

6. So don’t disappoint, and when you’re done, press the enter key 
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With a custom Folder added to a custom Cabinet, when you leave the Vault editor and 
switch back to the Vault (by pressing the [-] icon) you’ll see the custom Cabinet listed at the 
top of the Vault list. 

 

Renaming Custom Cabinets and Folders 

We’ve all been there; you’ve set your nice new custom Vault structure up only to find a typo in 

one of the descriptions.  That’s ok, you think, you’ll leave it, it won’t bother you.  But it does, it 

gnaws away, a little reminder that you should pay more attention when typing.  Never fear we 

say, in just a few short steps using the Vault editor, you can have that problem sorted and the 

peaceful calm will descend once more.   

 

1. First up, make sure you’re looking at the Vault, so that you can see this icon (to make 

certain, click Your Vault from the View menu) 

 

 
 

2. Click the small [+] icon, next to the Vault icon to change to the Vault editor; you’ll see 

the text change, and the [+] icon changes to [-] like so. 

 

 
 

3. Now highlight the custom Cabinet (or Folder) that you’d like to rename 

 

 
 

4. Click the Rename button at the bottom of the Vault editor 

 

 
 

You could also right click the custom Cabinet or custom Folder in the Vault editor 
and choose Edit Description from the menu, if you were so inclined. 
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5. After you’ve clicked the button, or you’ve selected the item from the menu.  The 

custom Cabinet (or Folder) will be ready for you to edit 

 

 
 

6. When you’re done, press the enter key and the updated description will be live across 

the program immediately 

 

 
 

The eagle eyed amongst you will have seen that on the menu we used the term Edit 
Description, whilst on the button we have Rename.  There are actually a couple of good 
reasons for this.  First up, Edit Description doesn’t fit on the width of the button.  But, more 
importantly, Edit Description is already used within the Vault for editing the pre-defined 
Cabinets and Folders.  And guess what?   You can edit the description from the Vault, just 
like you can for the pre-defined Cabinets and Folders.  How’s that for neat? 

 

Deleting Custom Cabinets and Folders 

So, you’ve been creating custom Cabinets and Folders, but now you’ve settled on the perfect 

organisation structure for your documents.  But you have some custom Cabinets and Folders that 

are now surplus to requirements.  So, how to get rid of them?  Why, follow the next XX steps of 

course!! 

 

1. Firstly, you’ll need to be in the Vault area, so that you can see this icon (to make certain, 

click Your Vault from the View menu) 
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2. Click the small [+] icon, next to the Vault icon to change to the Vault editor; you’ll see 

the text change, and the [+] icon changes to [-] like so. 

 

 
 

3. Now highlight the custom Cabinet (or Folder) that you’d like to delete 

 

 
 

4. Click the Delete button at the bottom of the Vault editor 

 

 
 

You could also right click the custom Cabinet or custom Folder in the Vault editor 
and choose Delete from the menu, if you were so inclined. 

 

5. After you click the button (or menu), you’ll see a confirmation message just like the one 

below – heed the warning…. 

 

 
 

6. If you do click Yes, then the custom Cabinet or Folder will be deleted and that will be 

the end of that 

 

If you do this to a custom Cabinet, all of the custom Folders belonging to the 
custom Cabinet will be deleted as well.  A bit like a domino effect, one goes they 
all go.  Just something to be aware of, before you get a little delete happy. 
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To delete or not to delete, that is the Option 

We’ve just highlighted a fairly straight forward delete process for the custom Cabinets and 

Folders (and if you haven’t read that yet, what are you doing here?), but there is one restriction 

imposed on the delete process that has to be adhered to.  If a document still exists on your 

system and it belongs to a custom Folder (Cabinet) that you are trying to delete, you will be 

unable to continue.  The program will put the brakes on and that will be that. 

 

You must do one of two things to overcome this 

 

1. Move the document (or documents) to another Folder; it doesn’t matter if that’s a 

custom Folder or pre-defined Folder.  However, in the case of a custom Cabinet being 

deleted, the document can’t be moved to a custom Folder belonging to the same 

custom Cabinet 

 

2. Delete the document (or documents) and also purge them from the Trash 

 

This check is installed to prevent documents being orphaned (no one wants to see that; orphaned 

documents get quite upset).  This would occur if a document resided in the Trash, and you 

attempted to restore it to a custom Folder that no longer existed; so we’re really mean and don’t 

let you do it. Sorry about that. Move on now, nothing else to see here. 
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Reminders Revamped 

Ah, Reminders; once buried within the Options screen now promoted to be right up there with 

the Vault.  Who’d have thought it?  Well, actually it was some bright spark at Xpress Document 

Solutions Limited who thought it would be a good idea.  The code monkeys got their brief; the 

rest they say, is history.  If you’re not seeing the screen below then you’ll need to select Your 

Reminders from the View menu. 

 

 
 

The left hand side of the screen displays your Reminders (you know, that important date you set 

when you added a document or remembered something while you were browsing your Vault) in 

date order with the item requiring attention the soonest listed at the top.  Scroll down the list (if 

you have more than one obviously) and you’ll see the document on the right changes, neat don’t 

you think? 

 

Reschedule a Reminder 

1. If you’re not viewing the list of Reminders then you’re really going to struggle with this 

next bit, so may we suggest that you click Your Reminders from the View menu  
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2.  Select from the list the Reminder that you would like to reschedule and click the button 

Reschedule (we really like to keep this as straight forward as possible you know!) 

 

 
 

3. You’ll now see the Amend Reminder Details window in the centre of the screen  

 

 
 

4.  To change the Reminder date, select the first check box and use the date selector to set 

the new date 

 

 
 

5. You’ll notice that you can (if you’re so inclined) change the Reminder details.  Select the 

check box to enable the drop down list which will allow you to do just that 
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6. When you’re done, click OK and you’ll see your Reminder has been updated in the list 

 

 

Delete a Reminder 

Reschedule this, reschedule that, myhomefiling is as flexible as you need it to be.  But what can 

you do with Reminders that you no longer need?  Well, we’ve made it pretty straight forward if 

we do say ourselves.  So lets’ give you the 3 step plan of action and say adios to those surplus 

Reminders 

 

1. To delete a Reminder you’ll need to be viewing the available Reminders.  You should 

know the drill by now;  click Your Reminders from the View menu 

 

2. Select from the list the Reminder that you would like to reschedule and click the button 

Delete (we really like to keep this as straight forward as possible you know!) 

 

 
 

3. If all goes well, this message appears and the Reminder shall be gone.  

 

 
 

Create an iCalendar File 

Ok, we’ll hold our hands up and admit it; what we’ve covered in rescheduling and deleting 

Reminders isn’t new.  It’s just been moved from the depths of the Options screen and given a 

front row seat so that it can play a more important part in your filing routine.  But we do have a 

brand spanking new feature for you to use and that’s the option of creating an iCalendar file. 

 

Ooooh we hear you cry, what’s this?  Well, rather than let us try and explain, we’ve borrowed this 

useful snippet of text from the mighty Google. 

 

http://support.google.com/calendar/bin/answer.py?hl=en&answer=37108
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“iCalendar, often referred to as iCal, is a standard internet calendar format that enables users to 

create and share electronic calendars across different computers and different programs. 

As the format continues to grow in popularity, many companies have chosen to use the iCalendar 

standard. Apple's iCal, a personal calendar application that runs on the Mac OS X operating 

system, is one of many programs that currently use this format. Others include Mozilla Sunbird 

and Microsoft Outlook.” 

 

So there we have it.  That’s what they’re about.  But why would you want one?  Well, as the 

quote above says; these files can be used with quite a few popular email and calendar programs, 

so you need never miss a Reminder again, and here’s how: 

 

1. First things first, make sure that you’re looking at the Reminders.  click Your Reminders 

from the View menu 

 

2. Select from the list the Reminder that you would like to create the iCalendar entry for and 

click the button Create iCal  

 

 
 

3. You’ll now see a Save As dialog window appear.  Select a location where you would like to 

save the iCalendar file to, provide a name for the file and click Save 

 

 
4. The file will be created and you’ll see the message below on your screen.  If you have a 

program on your computer already that uses iCalendar files (such as Microsoft Outlook) 

you can click Yes to open the file in that program to edit the details further 
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We like this feature a lot, but it does have a few limitations that we need to make you 
aware of.  You may find that you have no default application associated on your computer 
for the iCalendar file format.  Clicking Yes in step 4 above will cause a message to be 
displayed saying something along the lines of Windows being unable to open the file, do 
you want to open with a program installed on the computer or use a web service to find 
the correct program.  If you use a web based calendar application – such as Google’s Gmail 
– you can ignore this message and upload the saved document to Gmail.  If you don’t have 
a suitable program installed, you may want to do some research on the internet for 
something that fits your needs. 
 
Another thing to be aware of is that once you export the Reminder to be used in another 
program, myhomefiling can’t alter the information in that program.  For example, if you 
delete a Reminder from myhomefiling it wouldn’t delete a corresponding entry in say 
Microsoft Outlook. 
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myhomefiling Monitor 

The myhomefiling monitor is a small program which runs when you log into your computer.  This 

program used to serve just two purposes, but it’s been given a little pep talk and now it’s ready 

for the big time.  It can still monitor (were we on fire with our naming convention or what?) your 

reminders - if you don’t know what reminders are, then you’ve missed few chapters, see here for 

info.  It’s still able to handle the “Send To” Windows function, where you send one of your 

documents to myhomefiling without having to start the entire program (even though 

myhomefiling  is quick when you want to add a document, it is trumped on pure speed by the 

monitor!). 

 

So what’s new I hear you cry, well, they say a picture is worth a thousand words – so have a 

gander at this 

 

 
 

So, starting at the top, you can now launch the main myhomefiling program directly from the 

monitor; we’ve mentioned that you can monitor your reminders, but as you can see that at your 

fingertips (or should that be mouse tip?) you can open InTray and Trash; and, you can get the 

myhomefiling monitor to process the Watch Folder – just on the off chance a document was 

added whilst the monitor wasn’t running. 

 

The myhomefiling monitor lives in the taskbar near to the clock.  When you see this icon   you 

know the monitor is running 

 

To close the myhomefiling monitor down, right click the icon in the task bar and select Close 

myhomefiling Monitor Service.  You’ll need to confirm that you want to do this, click Yes and the 

monitor will gone faster than a dog chasing a rabbit. 
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Reminders 

Viewing your reminders is almost is as easy as it is to add your documents in the first place.  To 

view them you follow these 2 easy steps: 

 

1. Right click the monitor icon in the task bar and select the Show My Reminders menu 

item 

 

 
 

You’ll notice the last  menu item there ‘Close myhomefiling Monitor Service’.  This 
does exactly as the name implies, it closes the service down.  You will be 
prompted to confirm your decision to stop you from accidentally closing the 
monitor. 
 
 If you do confirm that you wish to close the monitor, you will no longer receive 
notifications or be able to access the reminder list from the task bar.  The monitor 
will restart when the computer is restarted and you can also manually restart the 
monitor by clicking the shortcut in the Start Menu folder where myhomefiling was 
installed. 

 

2. There we have it, your list of reminders!  
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Click the ‘Close’ button to close the reminder list when you are finished.  

 

Just being able to view the reminders is only partially useful though, because you probably need 

information from the document that you added the reminder to.  To help, you can right click on 

entries in the reminder list to access the context menu (shown below). 

 

  
 

 

Each option does exactly as described; clicking View Document will display your document on the 

screen in a mini version of The Viewer.  Reschedule Reminder will allow the date and the details 

of the reminder to be changed and Delete Reminder will remove the reminder from 

myhomefiling completely. 

 

Reminders Popup 

Another useful feature that the monitor has is a popup that can be quickly accessed to see how 

many reminders have either passed or are due today.  This will automatically show once a day 
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(when the computer starts or when the computer clock rolls past midnight), but you can also 

display the popup by left clicking the icon on the task bar, like so: 

 
 

Send To 

The concept of “Send To” has been around in the Microsoft Windows operating system for many 

years.  It provides a fast, easy way to open (send) a file to a particular program, without first 

having to open the required program, then go through a painfully slow File > Open > Browse 

routine.  

 

When you install myhomefiling you will see that you can now “Send To” myhomefiling just by 

right clicking on a document (see below). 

 

   
 

When you use this feature, you’ll jump right in at the second step of the Add Document Wizard 

without having to start the main program at all, which is really useful if you come across a 

document which you forgot to file! 
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Watch Folder 

Watch Folder is a folder that the myhomefiling monitor watches (how great are we with the 

informative naming conventions!); specifically when a document is created (added) to that folder 

the document will be scanned, and if it’s a document that myhomefiling supports the monitor will 

whisk it off to InTray. 

 

Ok, so that’s the crux of it; but your brain can be heard here, pondering the usefulness of this 

thing we call the Watch Folder.  So, before we get into the nitty gritty of setting this up, we’ll 

cover two of the main reasons why the Watch Folder can/will be used. 

 

First up, we have those of you reading this that don’t possess a document scanner that ships with 

a TWAIN driver – yes dear Fujitsu ScanSnap reader, we’re talking to you!  Document scanners like 

these have to be used with the scanning software that ships in the box, which means that they 

can’t be used directly by third party programs like myhomefiling.  What they do have though, is 

the ability to scan directly to a folder…… If that folder is the myhomefiling Watch Folder, then hey 

presto – paper to program with minimum of fuss. 

 

  

Now if you’re one of those people who like to use a certain version or a specific program, that’s 

long been obsolete – chances are you’re stuck with a program that uses a document format that 

can’t be used directly with myhomefiling – we’re talking about programs such as Microsoft 

Money 2000 and the like.  The chances are, you have records (and or documents) that you’d like 

to be able to search from myhomefiling.  So how do you get the documents in there?  Well, with 

the aid of a PDF Printer Driver and Watch Folder you can do just that! 

 

In short, with a PDF Printer Driver installed, you can print your document to, well, a PDF (we’re 

not the only ones with the informative naming conventions).  Typically, during the “printing” 

process you are asked where to save the document to – if you select Watch Folder, as soon as the 

document finishes printing – guess what? Yep, that’s right; it’ll be whisked off to InTray. 

 

Configuring the Watch Folder 

1. Start myhomefiling if it’s not already running – you should be well versed in this now, 

but if you’ve forgotten how to do it (shame on you) the shortcut should be on your 

desktop (or in the All Programs menu) or you could even use the shortcut on the 

monitor menu 

 

2. From the Tools menu, click Options 

 

http://www.google.co.uk/#hl=en&xhr=t&q=free+pdf+printer+driver&cp=17&pf=p&sclient=psy&source=hp&aq=0&aqi=g5&aql=&oq=free+pdf+printer+&pbx=1&bav=on.2,or.r_gc.r_pw.&fp=a2eda48bf653b863&biw=1440&bih=809
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3. Select the Watch Folder tab from the Options screen 

 

 
 

4. To enable Watch Folder, you need to tick the Enable the Watch Folder Monitor  

 

 
 

To disable Watch Folder just untick Enable the Watch Folder Monitor 

 

5. Click the Select button 

 

 
 

6. The standard Microsoft Windows folder browser dialog box will appear.  Use this to 

select the folder that you want to ‘Watch’ and click OK 
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7. The folder you selected in step 6 will now be displayed in the text field, and that’s it (in 

fact, as soon as you click OK in step 6 the whole Watch Folder process becomes active!) 

 

 
 

Just so you know we know (oooh err) that this isn’t really the most convenient place to 
access the configuration of the Watch Folder as it means you need to start the main 
program.  We’re working on adding a shortcut to the monitor menu. It’s just missed the cut 
off date for the current release – sorry. 

 

Adding Files to the Watch Folder 

Adding files to the Watch Folder – we’ve covered two ways at the start of this section.  But what 

are the other ways of using the Watch Folder; well, basically, any cut, copy, paste, move, save and 

create new action that takes place in the folder you’ve selected will kick the process off!  

 

The Watch Folder doesn’t work when the myhomefiling monitor isn’t running.  If you place 
a document into the Watch Folder and the myhomefiling monitor wasn’t running at the 
time, even when you start the myhomefiling monitor the document will not be picked up.  
The key here is that the Watch Folder is being checked for documents that are ‘created’.  If 
the myhomefiling monitor detects an ‘existing’ document, it will be ignored.  Not to worry 
though, there’s a manual option to process the Watch Folder.  Can you remember where? 
Yep, that’s right, it’s on the myhomefiling monitor menu that we discussed earlier in this 
chapter. 
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Hints and Tips 

The Vault 

The vault keeps a lot of its secrets hidden away until you start to add documents to it, then 

they’re all exposed for the world to see – and these secrets will help you use myhomefiling even 

more effectively! 

Renaming the Cabinets and Folders 

OK, so strictly speaking renaming the cabinets and folders can happen at any time, but until you 

start to build up your documents in the vault, you may spend more time restoring the original 

names than filing if you’re not careful.  Anyway, we know that the predefined list of cabinets and 

folders is pretty good and it’s one of the reasons that people recommend the software, but we 

also know that not everyone thinks the same – especially when it comes to classifying documents.    

So, to ensure no one feels left out, it’s now possible to change the names of the cabinets and 

folders.  Hurray we hear you shout, but how do you do this? Well, you follow these three handy 

little steps like so: 

 

1. Right click the cabinet that you wish to rename, from the menu, select the option to 

Edit Description 

 
 

2. Type a new description for the cabinet 

 

 
 

3. Press Enter and the change will be made throughout myhomefiling 

 
 

 

If you’re thinking of renaming a folder instead of a cabinet, you can still follow the previous 
steps; just select the appropriate folder in step 1. 

 

 



 

 

53 myhomefiling 

User Guide - Page 53 of 74 

 

Restoring the Original names 

If you decide that you don’t like the new description you’ve given to a cabinet or folder, you can 

quickly revert to the predefined name by following these steps:  

 

1. Right click the cabinet that you want to revert to the predefined description, from the 

menu select the option to Restore Original Description  

 

 
 

2. And there you have it, the cabinet name will revert to the original myhomefiling 

description 

 
 

If you’re thinking of restoring a name of a folder instead of a cabinet, you can still follow 
the previous steps; just select the appropriate folder in step 1. 

 

Move a Document to another Folder 

If you find yourself in the position where a document you’ve added should really belong in a 

different folder, you can quickly move it by dragging it to the desired location, like so: 

 

1. Left click and drag the document you want to move (you will see an outline of the 

document follow the cursor) 

 

 
 

2. When you’ve dragged the document over the folder you wish to move your document 

to, release the mouse button and hey presto, you’re document will be moved! 
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Edit Description 

The default ‘description’ for a document when it is added to myhomefiling is the date that the 

document reached the vault.  Although this can be changed when you add a document, a lot of 

people stick with this because it’s fast and it’s easy to see a chronological history of the 

documents when you expand a folder.  But what happens if you change your mind at a later 

date? Well, you can edit the description by following these next steps: 

 

1. From the vault, right click the document you wish to edit the description of and click 

Edit Description 

 

 
 

2. This will allow you to type a description for the document.  When you are finished press 

the Enter key 

 

 
 

3. Your document will now be listed in the vault with its new description 

 

 
 

 

 

 

 

 

 

 

 

 



 

 

55 myhomefiling 

User Guide - Page 55 of 74 

 

Add a Reminder 

We’ve discussed reminders several times in throughout this guide, but we’ve only seen them 

created when you use the Add Document Wizard or the InTray.  If you forget to add a reminder at 

either of these points though, all is not lost.  You can add a reminder to a document simply: 

 

1. From the vault, right click the document you wish to add a reminder to and click Add a 

Reminder 

 

 
 

2. Select the date the reminder is due and what the reminder is for, then click OK to return 

to the vault.  The reminder will be set and you can view it easily to amend or delete it 
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Trash a Document 

From time to time, we all put things where we shouldn’t and filing documents is certainly no 

exception.  If you come across a document that has no real place in myhomefiling then you can 

ship it off to the Trash quick as a flash.  To send a document to the Trash: 

 

1. From the vault, right click the document you wish to send to the Trash and click Delete 

from Vault 

 

 
 

2. If you’re certain you want to delete the document from the vault, click Yes otherwise 

click No 

 

 
 

3. The document will be shipped off to the Trash, the vault will refresh and the counter 

will show one less document.  The Trash counter will increase by 1 

 

Restore a Document from the Trash 

The Trash area has been introduced to act as a safety net when you delete a document (just like 

the Windows Recycle Bin) so that you have a chance to recover your document if you accidentally 

delete it.  To restore a document from the Trash: 
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1. Click the View menu, and select Trash (or you could click the icon in the Status Bar, or 

use the myhomefiling monitor menu – the choice is yours) 

 

2. This will display the Trash screen as shown 

 

 
 

3. Select the document you wish to restore from the list of deleted documents on the left 

hand side of the screen 

 

4. Click Restore and the document will be transferred back to the Vault 

 

Permanently Deleting Documents from the Trash 

If you’re completely sure that the documents in the Trash are to be deleted permanently, then 

you’ll need to empty the Trash.  To do this: 

 

1. Click the View menu, and select Trash (or you could click the icon in the Status Bar, or 

use the myhomefiling monitor menu – the choice is yours) 
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2. This will display the Trash screen as shown 

 

 
 

3. At this point, you can either select each document individually, and click Delete or, you 

can click Delete All to remove everything in one go 

 

4. You will see a confirmation box, and, if you’re still sure that you wish to delete the 

documents, click Yes otherwise, click No 

 

 
 

 

View a Document Full Screen 

To open a document full screen for reading, double click the appropriate document icon in the 

Vault and our standalone viewer will be presented to you in all its stripped down glory.  To close 

the full screen view, select Exit from the File menu. 
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Open in Windows Default Application 

Our in built document viewer provides basic functionality for displaying and navigating your 

documents (and some quite advanced features in the case of Microsoft Office documents); but 

we know that sometimes, the features offered by dedicated applications are really useful.  That’s 

why we’ve added the ability to open the documents from the Vault using the default applications 

on your computer.  To do this: 

 

1. From the vault, right click the document you wish to open and click Open in Windows 

Default Application 

 

 
 

2. The application designated as the default application  for the type of file (for example 

Adobe Acrobat for PDF documents) will then open your document  

 

 
 

Although this opens the documents from the Vault (rather than a copy) changes to the 
content will not be saved back to the database. 
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Program Maintenance 

Backing up Your Vault 

Filing your documents away in myhomefiling is a great way to organising your filing, but if you 

forget to take regular backups, then if the worst happens to your computer, you could find 

yourself with a considerable problem.  myhomefiling includes its own backup function for this 

very reason and if you get into the habit of regular backups then you’ll never need to worry. 

 

 To start the backup function from myhomefiling: 

 

1. Click the Options menu  item from the Tools menu 

 

 
 

2. Ensure that the backup tab is selected.  On this tab you will see three “groups”.   

 

 
 

3. The first “group” on the screen, is that of Backup Description.  You can think of this as a 

label for the backup contents.  If you leave Automatic Description checked, the batch 

will be labelled with just the current date and time, which may be all that you need, but 

if you un-tick this option, you can specify a more meaningful description such as ‘April 

09 inc All Bank Statements’, ‘Backup before adding payslips from last 10 years’ etc.   The 

choice is entirely up to you. 
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1. The second of our “groups” is Backup Destination, and just like the name implies, this is 

where the backup should be saved to.  There are two options available to you at this 

point and the option you select affects what happens next 

 

If you select 

 

a. CD or DVD Writer 

 

i. From the drop down list of detected CD or DVD writers, select the 

device that you will be putting your blank media into to finish creating 

your archive 

 

 
 

If you select 

 

b. My Documents, USB Key, Pen Drive, External Hard Drive 

 

i. Click the Select button 

 

 
 

ii. Select the location (and optionally a folder) where you want to save 

your backup to and click OK 

 

 
 



 

 

62 myhomefiling 

User Guide - Page 62 of 74 

 

iii. The path you selected will now be shown on the screen 

 

 
 

 

4. When you’ve decided on where you’ll be backing up your vault to, you can then click 

the Backup button.  The progress will be reported in the third “group” on the backup 

tab 

 

 
5. This can take a while to complete if you have lots (1000’s) of documents and if you’re 

creating the backup on a CD or DVD, but once the job is done, you’ll see a message to 

say everything completed successfully 

 

 
 

Restoring Your Vault from a Backup 

Being able to restore what you have backed up is as important as backing up in the first place, as 

well as it being a key element to getting you up and running again quickly should the worst 

happen to your computer. 

 

To start a restore of your myhomefiling vault: 

 

1. Click the Options menu  item from the Tools menu 
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2. Ensure that the Restore Vault tab is selected  

 

 
 

 

 

3. First you need to decide which backup you would like to restore from, to do this first 

click the Select button 

 

 
 

If your backup is on a CD or DVD now would be a good time to pop it into the 
appropriate disc drive on your computer  

 

4. From the file selection screen, browse to the location of your myhomefiling backup and 

select the backup file you wish to restore from 
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5. When you click open in the previous step, the details will be loaded from the file for you 

to review before proceeding with the restore 

 

 
If your backup is on a CD or DVD please make sure that you have all of the discs 
that make up the backup otherwise you will break your vault by not having all of 
the correct information.  You can verify how many discs you should have by the 
value next to ‘Number in Set’ on the summary screen. 

 

6. Before you begin the restore, you should decide what the program will do if it 

encounters an existing file.  The default option is to Overwrite Existing Files.  You 

should leave this option ticked unless you wish to only restore a file or files that have 

been deleted by accident, then you should untick it. 
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7. When you’re good to go, click the Restore button.  When the restore completes, you’ll 

see the following message 

 

 
 

If your backup is on CD or DVD and there are several of them, you will be 
prompted to insert each disc when required. 

 

Moving Your Vault 

If you find yourself running low on disc space or you would like to have your documents on an 

external drive (or for the lucky few a central server), you’ll need to use the myhomefiling 

migration utility.   

 

To move your myhomefiling vault: 

 

1. Click the Options menu  item from the Tools menu 

 

 
 

2. Ensure that the Vault Location tab is selected 

 

 
 

3. The current location of the vault will be shown on the screen 
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4. Click the Select button after reading through the information panel 

 

 
 

5. Use the folder browser screen to select the location you would like the vault to be 

moved to.  Once you have selected your location, click OK 

 

 
 

 

 

 

 

6. Finally, click the Migrate button to begin the process.   
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7. This will take a little time if you have 1000’s of documents, but once complete you will 

see the following message.  Click OK to continue using myhomefiling with the vault in its 

new location 

 

 
 

Connecting to a previously Moved vault 

If you make the decision to Move your vault, a need may arise to reconnect to that Vault.   

 

Consider this scenario; you have been happily working with your computer and the myhomefiling 

software for some time.  You have amassed a large number of documents, but it’s time to 

upgrade your computer.   

Checking for Updates 

As we described in the chapter “Exploring the Program”, it is possible to update the myhomefiling 

software from within the program itself, saving you the time and effort involved in remembering 

to visit our web site for updates.   

 

To update the program, follow the steps below: 

 

1. From the Help menu, click Check for Updates 

 



 

 

68 myhomefiling 

User Guide - Page 68 of 74 

 

 
 

2. If there is an update available, you will see the following message box, click Yes to 

download the update 

 

 
NB: Clicking No will halt the update process; you will need to start from step 1 again to attempt to update the program 

 

3. Select the folder where you would like the update to be downloaded to and click OK 
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4. myhomefiling will now be downloaded to the folder you selected in the previous step 

 

 
 

5. When the download is complete, you will be asked if you wish to run the update now.  

Click Yes to install the update.  myhomefiling will then close, and the installation 

program will begin.  This is the same process as described in the ‘myhomefiling 3.5 

Installation Guide’ 

 

 
 

 

 

If you click No at this point, the update will not proceed but myhomefiling will be aware 
that an update has been downloaded.  The next time you start myhomefiling, you will be 
asked if you wish to perform the update.  If you click No again, the download will be 
deleted and you will need to perform the Check for Updates process again. 
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Updating License Information 

If you decide that you like myhomefiling enough to purchase a license, you’ll receive a license key 

by email after the purchase process is complete.  Once you get this, you’ll need to add it to 

update your system.  To do this, follow the steps below: 

 

1. When you receive your email from myhomefiling with the license key attached, save 

the file to your computer.  Remember the location as you will need to find the file in 

step 3 

 

2. From the Help Menu, click License Information 

 

 
3. From the License Manager screen, click Browse 
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4. Browse your computer to find the myhomefiling.info file that you saved in step 1, select 

it and click Open 

 

 
 

 

 

5. When you are back in the License Manager screen, click Install 

 

 
 

6. You will receive a confirmation message if the installation of your license is successful.  

Click OK to close the message 
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7. The license information for your system will now be shown on the screen 

 

 
 

 

8. You will need to restart myhomefiling in order for the changes to be recognised.  Click 

Yes if you wish to do this immediately, otherwise click No and the changes will be 

loaded the next time you start myhomefiling 
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General Program Information 

From version 3.0 (r1) of myhomefiling onwards, the default software library used to scan and 

display documents has changed.  For the most part, the changes are buried deep (deep, deep) 

within the depths of myhomefiling code (where only the code monkeys dare venture), but what it 

means to you is full blown support for the PDF file format (about time we hear you cry!).  In short, 

this means that: 

 

1. The default file format of scanned documents is now PDF instead of TIFF 

 

2. PDF documents that are imported (say your bank statements or utility bills) can now 

have their content searched (where previously only the description was searched) 

 

3. If you perform a search and one of the documents in the Vault is a searchable PDF 

document (by that we mean one with searchable – hidden - text), then when the 

document is selected within the Vault the term that is being searched will now be 

highlighted on the page 
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Notices 

Contents of this document are copyright ©2014 Xpress Document Solutions Limited 

 

Reproduction in part or full for use other than the normal operation of the software without the 

prior consent of Xpress Document Solutions Limited is expressly prohibited. 

 

Xpress Document Solutions Limited can be contacted in the following ways: 

 

1. By Post 

Xpress Document Solutions Limited  
No. 2 Alderley Rise 
Hadderidge Gardens 
Burslem 
Stoke-on-Trent 
Staffordshire 
ST6 3EN 

United Kingdom 

 

2. By Email: 

support@xpressdocs.co.uk 

 

 


